K2 Website Builder experiencing AWS related outage
Incident Report for BuildYourSite.com
Resolved
AWS S3 had a major outage on the East coast on 2/28. The issue was resolved about 5 pm EST on 2/28. All services are normal. Again, we apologize for the inconvenience this caused.
Posted about 2 years ago. Mar 01, 2017 - 09:50 EST
Update
We're continuing to work with AWS to identify the underlying issue and mitigate its impact. Many parts our K2 platform will remain unstable or unavailable until further notice, and some running apps are being affected. The majority of our hosting customers are unaffected. We apologize for this issue.
Posted about 2 years ago. Feb 28, 2017 - 14:20 EST
Identified
We are working with our partners and Heroku and AWS to resolve an issue in one of our data centers.
Posted about 2 years ago. Feb 28, 2017 - 13:16 EST