K2 Service Degraded
Incident Report for BuildYourSite.com
Resolved
K2 degradation has been resolved. All sites are operational. We apologize for this issue.
Posted almost 2 years ago. Jul 27, 2017 - 17:48 EDT
Investigating
We are currently investigating an issue with our K2 platform. Engineers are working on it. We apologize for the inconvenience and will update this page once it's fixed.
Posted almost 2 years ago. Jul 27, 2017 - 17:04 EDT